Jump to content

Join our Slack

Talk to other users and have a great time
Slack Server

Welcome to our Community

Click here to get your Exiled Bot license
Donation Store

Recommended Posts

my script stoped changing zones.

 

i've just changed profile and zones, is there a way to debug why isn't changing zones now?

No, there is no way to debug this for the moment. We'll have to through this step by step :/

Have you tried undo the changes back to the state where the script worked for you?

 

 

im baffaled, i cant figure why it doesn work, one minute it works, and then the little timer just dissapears :S

So the script is running without any problems for a while. But at some point the timer indicator suddenly disappears without that you have done anything?

Does the Timer only disappears or does or does the zonechanging stop working for you also?

Share this post


Link to post
Share on other sites

i have it set up for 2 profiles, i think thats the problem. When the timer counts it works, but when there is no timer it doesnt, but i can see it running in the bottom right corner. Will try to reset everything to default settings, no profiles and see whats what :)

PS is there any special way to start the script, what has to be running? etc.

Tried everything from scratch and it still doesnt work. Sometimes the timer just dissapears after a couple of runs, sometimes it doesnt appear at all. All in all its not working for me :/

Ive tried running everything as admin changed all the rights of all the inis and all but still doesnt work.

Im running the another ahk script for the flasks, could that be interfering it?

Edited by Ferlez

Share this post


Link to post
Share on other sites

No, there is no way to debug this for the moment. We'll have to through this step by step :/

Have you tried undo the changes back to the state where the script worked for you?

 

 

thanks for your time, immo, I've checked again and compared installer files to find I introduced a typo :(

my bad.

I got another question anyway, how can deactivate vendoring? I just wanna stash everything "smart picking" takes in all stash tabs.

I see "Enable Stashint" in bot and number of stash in your script, but I can't find anywhere "Enable/Disable vendoring"

Edited by john9

Share this post


Link to post
Share on other sites

Im running the another ahk script for the flasks, could that be interfering it?

I'm running a Quicksilver Flask Script myself. So, no i dont think that would interfer anything...

Share this post


Link to post
Share on other sites

I'm running a Quicksilver Flask Script myself. So, no i dont think that would interfer anything...

 

 

Thx for all advice, I finally got i to work, I have to use default profile, and dont touch the stash settings and i'm fine :) 

Its working now. Hooray 

Share this post


Link to post
Share on other sites

Hi Immo,

 

Just a quesition, because I dont know it is normal or it is a bug. With this settings it works fine:

 

 

_numberOfZones = 2                                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped ("_zone_to_cleanX",              "_zone_to_clean_actX" and "_zone_to_clean_difficultyX").

_zone_to_clean1 = the_docks                       ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3                            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3                    ; enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_library                       ; enter desired Zone 2 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3                            ; enter desired act for Zone 2
_zone_to_clean_difficulty2 = 3                    ; enter desired difficulty for Zone 2 [1=normal, 2=cruel, 3=merciless]

 

But whit those it doesnt work, starts game and bot, but dont show the tooltip and doesnt work. The changes are the number of zones to 1, or number of zones to 2 but the same zone in both.

 

 

_numberOfZones = 1                                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped ("_zone_to_cleanX", "_zone_to_clean_actX" and "_zone_to_clean_difficultyX").

_zone_to_clean1 = the_docks                        ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3                            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3                    ; enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_library                        ; enter desired Zone 2 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3                            ; enter desired act for Zone 2
_zone_to_clean_difficulty2 = 3                    ; enter desired difficulty for Zone 2 [1=normal, 2=cruel, 3=merciless]

 

_numberOfZones = 2                                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped ("_zone_to_cleanX",              "_zone_to_clean_actX" and "_zone_to_clean_difficultyX").

_zone_to_clean1 = the_docks                       ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3                            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3                    ; enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_docks                       ; enter desired Zone 2 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3                            ; enter desired act for Zone 2
_zone_to_clean_difficulty2 = 3                    ; enter desired difficulty for Zone 2 [1=normal, 2=cruel, 3=merciless]

 

My idea is run bot in same zone all time but changing stash tabs.

 

Thanks, regards.

Edited by Raul

Share this post


Link to post
Share on other sites

yeah "_numberOfZones" has to be bigger then 1...

But you can easily enter the same zone for _zone_to_clean1 & _zone_to_clean2

_numberOfZones = 1                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped

_zone_to_clean1 = the_docks     ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3    ;enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_docks     ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3            ; enter desired act for Zone 1
_zone_to_clean_difficulty2 = 3    ;enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

i think i need to redo the script...

Share this post


Link to post
Share on other sites

Hi,

If you mean:

 

_numberOfZones = 2                                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped ("_zone_to_cleanX",              "_zone_to_clean_actX" and "_zone_to_clean_difficultyX").

_zone_to_clean1 = the_docks                       ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3                            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3                    ; enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_docks                       ; enter desired Zone 2 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3                            ; enter desired act for Zone 2
_zone_to_clean_difficulty2 = 3                    ; enter desired difficulty for Zone 2 [1=normal, 2=cruel, 3=merciless]

 

It doesnt works, not even shows the tooltip at start

Edited by Raul

Share this post


Link to post
Share on other sites

I have just updated the script. It should work properly with the latest version of EB again. Sorry for the delay...

 

------------------------------------------------------------------------------------------------------------------------

INFO!

ExiledBot.Zone.Changer.v1.9b
 

- working with the most recent EB version again

 

Be sure to have your file config'd correctly!!

------------------------------------------------------------------------------------------------------------------------

 

 

MWvmPK8.jpg

version: v1.9b

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

zip.gif  ExiledBot.Zone.Changer.v1.9b.zip   3.83KB   0 downloads

header_logo_shmodel-vflsZ7QsE.png  Dropbox [ext.download]

Share this post


Link to post
Share on other sites

Hi, doesnt working whit this config 1.9b neither

_numberOfZones = 2                                ; enter your desired number of different zones you want to use. If using less then 5 zones the unnecessary variables will get skipped ("_zone_to_cleanX",              "_zone_to_clean_actX" and "_zone_to_clean_difficultyX").

_zone_to_clean1 = the_docks                       ; enter desired Zone 1 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act1 = 3                            ; enter desired act for Zone 1
_zone_to_clean_difficulty1 = 3                    ; enter desired difficulty for Zone 1 [1=normal, 2=cruel, 3=merciless]

_zone_to_clean2 = the_docks                       ; enter desired Zone 2 [see coordinates.ini (Exiled Bot) to get the exact writings for the different zones!]
_zone_to_clean_act2 = 3                            ; enter desired act for Zone 2
_zone_to_clean_difficulty2 = 3                    ; enter desired difficulty for Zone 2 [1=normal, 2=cruel, 3=merciless]

Share this post


Link to post
Share on other sites

my bot crashes when I try to use the script, if I run the bot alone it doesn't crash but as soon as I run the script it doesn't work.

Problem signature:
  Problem Event Name:	APPCRASH
  Application Name:	ExiledBot.exe
  Application Version:	0.12.0.0
  Application Timestamp:	52f0e416
  Fault Module Name:	ExiledBot.exe
  Fault Module Version:	0.12.0.0
  Fault Module Timestamp:	52f0e416
  Exception Code:	c0000005
  Exception Offset:	00062e50
  OS Version:	6.3.9600.2.0.0.256.48
  Locale ID:	1033
  Additional Information 1:	5861
  Additional Information 2:	5861822e1919d7c014bbb064c64908b2
  Additional Information 3:	80a7
  Additional Information 4:	80a7ccd5015bce3d41120fe057d4f98f

Share this post


Link to post
Share on other sites

Not working for me, the tooltip says the zone has changed, but the bot is still entering the same zone.

 

19-02-2014 / 20:37:59: Exiled Bot started!
Zone and StashTab changes every: 25 Minutes!
19-02-2014 / 20:38:11: Zone changed to.....: the_city_of_sarn
                       StashTab changed to.: 1
_____________________________________________________________

19-02-2014 / 21:03:11: Zone changed to.....: the_docks
                       StashTab changed to.: 4

Share this post


Link to post
Share on other sites

------------------------------------------------------------------------------------------------------------------------

INFO!

EB-Tools.v2.01a
 

- working with the most recent EB version again (truly  :P)

- GUI added (based on MekongSwells's GUI)

- renamed

------------------------------------------------------------------------------------------------------------------------

 

version: v2.01a

------------------------------------------------------------------------------------------------------------------------------------

zip.gif  EB-Tools.v2.01a.zip   364.14KB   0 downloads

header_logo_shmodel-vflsZ7QsE.png  Dropbox [ext.download]

Edited by immo

Share this post


Link to post
Share on other sites

exile bot stopped working when i changed the max run time, otherwise looks great! When I leave it at 400 it works :)

Edited by Ferlez

Share this post


Link to post
Share on other sites

------------------------------------------------------------------------------------------------------------------------

INFO!

EB-Tools.v2.02
 

- added "Command-Line Parameter" Support

------------------------------------------------------------------------------------------------------------------------

 

 

6Hu9PNX.jpg

version: v2.02

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

Download1 (Post-Attachment) || Download2 (dropbox) ]

Edited by immo

Share this post


Link to post
Share on other sites

Hi all,

 

well i've got a problem.

When i launch it, i've to setup the 3 step .. but once done, the app go to minus (windows seven vm ware) and i dont have the config screen.

only minus icon on the windows

 

 

 

else , i tried on my seven (not vm ware system) and i't run good, i see the config screen ..

 

What can i do on vm ware to see it ?

 

thx

Share this post


Link to post
Share on other sites

Hi all,

 

well i've got a problem.

When i launch it, i've to setup the 3 step .. but once done, the app go to minus (windows seven vm ware) and i dont have the config screen.

only minus icon on the windows

 

 

 

else , i tried on my seven (not vm ware system) and i't run good, i see the config screen ..

 

What can i do on vm ware to see it ?

 

thx

Hi,

 

I have the same. The config screen is out of the screen. Increase the  screen resolution !

 

For me, the configured stashs don't work...the script uses other stashs than those configured. It works just fine for me with the same stashs and the 1.9 version

Edited by chen

Share this post


Link to post
Share on other sites

stupid question, what do command line parameters do? :)

 

Do not attempt to patch
--nopatch
 
If you add "--nopatch" to the end of your shortcut (without the quotes), does it still crash?
Do not preload art assets on startup
--nopreload
Override basic auth used for for patching content
-pa
--patching-auth
 
The number of generations to keep around when running garbage collection
-gc
--garbage-generations
 
Usage: -gc <generations> or --garbage-generation <generations>
 
you can put -gc 2 at the end of your Path of Exile shortcut (Open the shortcut properties, and add a { -gc 2} after the last quotation mark). If this still doesn't help, try -gc 1. Doing this will increase load times between areas you have visited, and similar areas.
 
I get an error message and a crash after playing the game for a while.
EOUTOFMEMORY or Unable to Map File
This usually occurs when your game file runs out of ram, common on PCs with low ram or running 32bit versions of windows. Running the game with Texture Quality set to Medium usually fixes this, though having less than 4gb of ram will cause problems after changing areas a number of times. We will improve the memory recovery system in future.
You can also reduce the rate of these crashes slightly by adding -gc 2
 
That's the best temporary fix until we're able to solve memory fragmentation!
Disables the creation of the audio device
-ns
--nosound
 
Added a --nosound option to the client to turn off all sound.
Forces use of generic software audio device
-swa
--softwareaudio
 
Players getting BSODs due to using a Creative soundcard should now try adding --softwareaudio to the command-line of the game.
Will always use default settings set in the settings.cpp
-ud
--use-defaults

Share this post


Link to post
Share on other sites

Quick question, are there any other dependencies to run this? It runs fine on my main rig, but on a VM it launches the config, I enter the parameters, and then it just swipes to the right of the screen, kind of like maximizing a window to another monitor, and I can't view the app.

 

Any ideas?

Edited by Tritech

Share this post


Link to post
Share on other sites

Quick question, are there any other dependencies to run this? It runs fine on my main rig, but on a VM it launches the config, I enter the parameters, and then it just swipes to the right of the screen, kind of like maximizing a window to another monitor, and I can't view the app.

 

Any ideas?

yeah the main window positions out of your screen if you have a low resolution.

 

yes the window is out of screen i will fix this asap

 

or increase you resolution

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...